WppaoImage插件使用需要哪些支持?

因为插件集成了图片水印,和远程图片下载到本地的功能。所以,对于运行环境是有一定的的要求的。

首先,虚拟主机和服务器运行环境只要设置正确,都可以正常使用。

如果你是Docker或者禁止写入磁盘的运行环境,那么可能无法正常使用,也不推荐使用。

其次,插件需要PHP7.2及以上版本支持,请将wp-content的uploads设置www权限和777写入。

文字水印是需要PHP安装了GD库支持,建议使用图片水印,要求没那么复杂,机器性能开销也低。

图片远程本地化需要PHP支持Curl。

 

综上所述,一个正常的虚拟主机和服务器运行环境都可以直接使用,不推荐Docker等封闭环境进行使用。